ActivityViewer.exe cant see Registered Servers

Jan 18, 2011 at 11:17 PM

I've battled through compiling ActivityViewer.exe (see below for steps) but now I just get the error "No registered servers found" when it launches.  I do have registered SSAS servers in SSMS.

My environment is SQL Server 2008 R2, without full Visual Studio, on Windows XP SP3.  The SSAS servers are on other machines - is that an issue?  I looked at downloading .NET Framework SDK 2.0, but ended up with Microsoft Windows SDK for Windows 7 and .NET Framework 3.5 SP1 following the recommendations on the download pages.

For the compile, I had to make two variations from the instructions:

  • it was looking for the SampleKey.snk file back 6 folders above the folder with the .csproj file (where I generated the SampleKey.snk file) - kinda weird but anyway I just copied it there...
  • the msbuild command was complaining about a missing property, so I added "/property:OutputPath=."

Any help would be great - or have I missed something and is this whole sample out-of-date now?

Thanks

Mike

Jan 19, 2011 at 3:16 PM

That silly "registered servers" thing is a bit annoying. If you can't get it to work, you might look at Activity Viewer 2008 (which is the same idea, but a completely different interface). It lets you register your servers from inside the app and doesn't require you register them from SSMS:

http://asactivityviewer2008.codeplex.com/

 

Jan 21, 2011 at 12:59 AM

Thanks Greg - the Activity Viewer 2008 works well right out of the box.